Após decidir mudar novamente a cara do blog, me deparei com uma mensagem de erro ao executar o Jekyll com as novas especificações:

public_suffix-3.0.0 requires ruby version >= 2.1, which is incompatible with the current version, ruby 3.0.0p648

Então minha alternativa foi: Vamos atualizar o Ruby! O que foi relativametne fácil, seguindo as instruções abaixo:

  1. Abra o terminal e execute:
    \curl -sSL https://get.rvm.io | bash -s stable
    
  2. Quando o comando acima terminar sua execução, você precisará reiniciar seu terminal para que o rvm funcione adequadamende, e após isso execute:
    rvm list know
    
  3. O comando acima exibirá as versões do Ruby, no meu caso a versão desejada era a 2.4.1, então bastou executar um:
    rvm install ruby-2.4.1
    
  4. Mas se você digitar no terminal ruby -v no terminal, ainda será exibida a versão antiga, a 2.0. Para então usar a versão mais atual que acabamos de instalar, execute:
    rvm use ruby-2.4.1
    
  5. Finalmente, para definir esta como a versão padrão do sistema, execute:
    rvm use ruby-2.4.1 --default